ChicagoZ.com- A Forum for Everything Nissan Z, 350z, 370z, Infiniti G35, G37, GTR, and MORE!  
     

Left Nav Register FAQ Members List Calendar Search Today's Posts Mark Forums Read Right Nav

Left Container Right Container
 
Please Support Our Sponsors

Go Back   ChicagoZ.com- A Forum for Everything Nissan Z, 350z, 370z, Infiniti G35, G37, GTR, and MORE! Announcements Site Feedback & Suggestions

Notices

Site Feedback & Suggestions For posting feedback, suggestions or questions regarding ChicagoZ.com

Reply
 
Thread Tools Display Modes
Old 04-07-2012, 10:31 PM   #1
kris575
n00b
 
kris575's Avatar
 
Join Date: Apr 2009
Location: Cicero
Posts: 27
iTrader: (0)
Default Clutch Problem??

Hey guys hopefully someone can help. I ran into a problem, well i hope its not a problem, but i first encountered it when i double clutched on the highway, when i accelerated my clutch pedal pulled back down on its own?? it happened again when i was turning left at a light and i accelerated hard to clear traffic which didnt work out to well cause my pedal did the same thing?? do any of you have any idea what might be wrong? its an 08 350z with 28k miles on it fully stock
__________________
Never go to bed with anyone crazier than you.
kris575 is offline   Reply With Quote
Old 04-08-2012, 12:08 AM   #2
medic165
Executive Status
 
medic165's Avatar
 
Join Date: May 2004
Location: Dupage county.
Posts: 2,315
iTrader: (2)
Default

post this on "car talk" for this kind of question. Good luck.
__________________
medic165 is offline   Reply With Quote
Old 04-08-2012, 02:45 AM   #3
kris575
n00b
 
kris575's Avatar
 
Join Date: Apr 2009
Location: Cicero
Posts: 27
iTrader: (0)
Default

will do. Thanks
__________________
Never go to bed with anyone crazier than you.
kris575 is offline   Reply With Quote
Old 03-29-2015, 02:07 PM   #4
Jeremylaf
n00b
 
Join Date: Dec 2014
Location: USA
Posts: 2
iTrader: (0)
Send a message via ICQ to Jeremylaf Send a message via Skype™ to Jeremylaf
Default Clutch Problem

Im having problems with my 1994 Passat. I ogt into the car this morning and passed the clutch pedal down and its now stuck there unless i pull it up by hand. Any answers??? Cheers
__________________
Big Forum LinksList for 10$
Jeremylaf is offline   Reply With Quote
Old 04-10-2015, 08:51 PM   #5
Lue's student
Site Fanatic
 
Lue's student's Avatar
 
Join Date: Oct 2009
Location: Aurora
Posts: 258
iTrader: (1)
Default

slave cylinder went bad
Lue's student is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 09:26 AM.


Powered by vBulletin®
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.